Healtech OBD tool - Suzuki GSXS1000 Forum
User Tag List

 3Likes
  • 2 Post By KiwiJaZ
  • 1 Post By bking1441
 
LinkBack Thread Tools
post #1 of 5 Old 09-03-2017, 09:48 PM Thread Starter
Member
 
KiwiJaZ's Avatar
 
Join Date: Jul 2016
Location: Wainuiomata, New Zealand
Posts: 82
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Garage
(Thread Starter)
Healtech OBD tool

I have just purchased the Healtech OBD tool for our bike (S-01) and keep getting communication failure errors when trying to connect.

On inspecting the SDS pug and the OBD tool connector the pins don't match up.

currently when connected, the following is achieved:

RED OBD – White/Red SDS (switched power)
White OBD – Blank SDS
Blank OBD – White/Red SDS
Black OBD – Black/Wht SDS (Grnd)
Green OBD – Grey/Red SDS
Blank OBD – Blank SDS

Does anyone else have the Healtech OBD tool and does it work correctly?

Honda MB50
Suzuki GS750
Honda CB550
Suzuki GSX750EX
Harley Davidson XL1200R
Suzuki GSX-S1000FA
KiwiJaZ is offline  
post #2 of 5 Old 09-03-2017, 10:42 PM
Senior Member
 
USSENTERNCC1701E's Avatar
 
Join Date: Apr 2016
Location: Utah, USA
Posts: 529
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 164 Post(s)
Garage
I don't, but I do have their Speedohealer. I highly recommend you email them directly, I had some trouble connecting the Speedohealer, and they were excellent to work with.

2016 GSXS1000FAL6
USSENTERNCC1701E is offline  
post #3 of 5 Old 09-03-2017, 11:01 PM Thread Starter
Member
 
KiwiJaZ's Avatar
 
Join Date: Jul 2016
Location: Wainuiomata, New Zealand
Posts: 82
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Garage
(Thread Starter)
have done but soooo impatient waiting for a repy :-)

Honda MB50
Suzuki GS750
Honda CB550
Suzuki GSX750EX
Harley Davidson XL1200R
Suzuki GSX-S1000FA
KiwiJaZ is offline  
 
post #4 of 5 Old 09-03-2017, 11:49 PM Thread Starter
Member
 
KiwiJaZ's Avatar
 
Join Date: Jul 2016
Location: Wainuiomata, New Zealand
Posts: 82
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Garage
(Thread Starter)
Problem solved.

Via Woolich I had enabled fast engine data.
I reflashed the ECU with this disabled and the Healtech tool connected fine.

Reset TPS learned value......

Honda MB50
Suzuki GS750
Honda CB550
Suzuki GSX750EX
Harley Davidson XL1200R
Suzuki GSX-S1000FA
KiwiJaZ is offline  
post #5 of 5 Old 09-04-2017, 09:55 AM
Senior Member
 
bking1441's Avatar
 
Join Date: May 2015
Location: Norway
Posts: 305
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 108 Post(s)
Garage
I had exactly the same experience/problem.

I also had problem with a Surface Pro that did not have (enough) power over USB when not on DC-power (this is still not fixed by MS I believe).

No point in using "fast engine data" if you have/use the Zeitronic WB-kit and use the data port.
Then you will see a much higher log rate (50 times pr.sec) in the logs (the "downside" is much larger logs of course).
I am not sure how this works, but I can see that the data from sds-line comes in at same rate as from Zeitronic controller. Which should be "impossible" as even "fast engine data" is not as "fast" as the Zeitronic controller.
So I am very unsure on what "fast engine data" actually does(or not) regarding communication rate over SDS-line.
Besides rendering the Healtech OBD device useless.
KiwiJaZ likes this.

2018 - Speed Triple S
2015 - GSX-S1000
2009 - B-King 1441

Last edited by bking1441; 09-04-2017 at 05:00 PM.
bking1441 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSXS1000 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome