New Throttle Tamer + Grips - Suzuki GSXS1000 Forum
User Tag List

 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 12 Old 07-17-2017, 11:02 PM Thread Starter
Senior Member
 
Reagenn's Avatar
 
Join Date: May 2017
Location: Southern Oklahoma, USA
Posts: 521
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 205 Post(s)
(Thread Starter)
New Throttle Tamer + Grips

Just got around to installing the TT and Pro Grips.
The bike rides very nice with TT along with a PCV, adjusted suspension and adjusted throttle cable.
For some reason, the bike actually feels faster...maybe not fighting the throttle lets you enjoy the power more!

I just realized that I really need to get those sticker off the tank! lol
Attached Images
File Type: jpg gsxs2.jpg (744.4 KB, 99 views)
TheDude likes this.

Last edited by Reagenn; 07-17-2017 at 11:06 PM.
Reagenn is online now  
post #2 of 12 Old 07-17-2017, 11:13 PM
Senior Member
 
mike d's Avatar
 
Join Date: Mar 2017
Location: Salt Lake City, Utah U.S.A.
Posts: 1,603
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 483 Post(s)
Garage
Looks great Reagenn (except the stickers).
I'm a big fan of Pro-Grips. Just put some on my bike too!
mike d is online now  
post #3 of 12 Old 07-17-2017, 11:33 PM
Member
 
scooterdavis's Avatar
 
Join Date: Apr 2017
Location: WA state
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Quick question: I just installed my PCV yesterday and on the bikes first test ride everything was vastly improved. Today riding to work, I noticed that the idle was at 1k (a little low I think) and the bike seemed to be running VERY rich, to the point of shuddering (mostly up until 5k in any gear). Any ideas?
scooterdavis is offline  
 
post #4 of 12 Old 07-17-2017, 11:47 PM Thread Starter
Senior Member
 
Reagenn's Avatar
 
Join Date: May 2017
Location: Southern Oklahoma, USA
Posts: 521
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 205 Post(s)
(Thread Starter)
Quote:
Originally Posted by scooterdavis View Post
Quick question: I just installed my PCV yesterday and on the bikes first test ride everything was vastly improved. Today riding to work, I noticed that the idle was at 1k (a little low I think) and the bike seemed to be running VERY rich, to the point of shuddering (mostly up until 5k in any gear). Any ideas?
Once warmed up, my bike idles at about the same. Not sure what is causing the shuddering...sure you got everything hooked up correctly?
Maybe the 02 optimizer isn't reading correctly?
If you can't figure it out, I would call Dynojet and see what they say.
Reagenn is online now  
post #5 of 12 Old 07-17-2017, 11:53 PM
Member
 
scooterdavis's Avatar
 
Join Date: Apr 2017
Location: WA state
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Quote:
Originally Posted by Reagenn View Post
Once warmed up, my bike idles at about the same. Not sure what is causing the shuddering...sure you got everything hooked up correctly?
Maybe the 02 optimizer isn't reading correctly?
If you can't figure it out, I would call Dynojet and see what they say.


Yep, I emailed Chris at DJ. It is weird, because it ran PERFECT on the first ride. I might need to try a different map, or possibly get a custom tune. Apparently if you unhook the positive battery lead it resets the computer (not sure if it resets the PC though). Are you using the provided map?
scooterdavis is offline  
post #6 of 12 Old 07-17-2017, 11:58 PM
Senior Member
 
PhuketPaul's Avatar
 
Join Date: Mar 2016
Location: Phuket. Thailand
Posts: 1,235
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 486 Post(s)
Garage
Quote:
Originally Posted by Reagenn View Post
Just got around to installing the TT and Pro Grips.
The bike rides very nice with TT along with a PCV, adjusted suspension and adjusted throttle cable.
For some reason, the bike actually feels faster...maybe not fighting the throttle lets you enjoy the power more!

I just realized that I really need to get those sticker off the tank! lol

Looking t your bars and in particularly the right hand switch, do you not get the hazard warning lights in the US either. Are they only on European bikes?

We don't have them in Asia
PhuketPaul is offline  
post #7 of 12 Old 07-18-2017, 12:22 AM Thread Starter
Senior Member
 
Reagenn's Avatar
 
Join Date: May 2017
Location: Southern Oklahoma, USA
Posts: 521
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 205 Post(s)
(Thread Starter)
Quote:
Originally Posted by scooterdavis View Post
Yep, I emailed Chris at DJ. It is weird, because it ran PERFECT on the first ride. I might need to try a different map, or possibly get a custom tune. Apparently if you unhook the positive battery lead it resets the computer (not sure if it resets the PC though). Are you using the provided map?
Yes I am, and it runs great. I wouldn't think you would need a custom tune.... you may have a faulty PCV.




Quote:
Originally Posted by PhuketPaul View Post
Looking t your bars and in particularly the right hand switch, do you not get the hazard warning lights in the US either. Are they only on European bikes?

We don't have them in Asia
I guess we don't, but I'm not sure who all gets them.
Reagenn is online now  
post #8 of 12 Old 07-18-2017, 12:25 AM Thread Starter
Senior Member
 
Reagenn's Avatar
 
Join Date: May 2017
Location: Southern Oklahoma, USA
Posts: 521
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 205 Post(s)
(Thread Starter)
Quote:
Originally Posted by mike d View Post
Looks great Reagenn (except the stickers).
I'm a big fan of Pro-Grips. Just put some on my bike too!
Thanks Mike, I'm loving them as well.
Reagenn is online now  
post #9 of 12 Old 07-18-2017, 01:55 AM
Member
 
scooterdavis's Avatar
 
Join Date: Apr 2017
Location: WA state
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Quote:
Originally Posted by Reagenn View Post
Yes I am, and it runs great. I wouldn't think you would need a custom tune.... you may have a faulty PCV.



That was my second thought. At least install #2 will go a **** of a lot faster...
scooterdavis is offline  
post #10 of 12 Old 07-18-2017, 06:14 PM
Senior Member
 
bgagnon's Avatar
 
Join Date: May 2017
Location: Quebec City
Posts: 105
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Garage
Quote:
Originally Posted by Reagenn View Post
Yes I am, and it runs great. I wouldn't think you would need a custom tune.... you may have a faulty PCV.













I guess we don't, but I'm not sure who all gets them.


Canadian market does without it also


Envoyé de mon iPad en utilisant Tapatalk

../Bruno

GSX-S1000F 2018 (my ride now)
F800GT 2015 (sold)
CB500X 2013 (sold)
bgagnon is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSXS1000 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome