GSXS 1000 Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi
Unfortunately, I have issues with my bike. If I pull the throttle aggressively, it is starting slow down and feels like its tossing me front to back, like its trying to throw me off, and definitely doesn't want to accelerate.
After 60 mins of downtown riding, I have also noticed this problem without pulling heavy throttle, and in this case, the engine was cut off. I could restart it while I was driving, but it has broken down again after a couple of seconds.
There was a certain case, when I did not succeed with restarting the engine, the starter was just trying to restart it...
Pulled out the key, restarted the engine, and it was OK for a couple mins.
These symptoms started to happen in this hot (35C) weather.
Any idea what is the problem? Fuel pump? TPS sensor? Overheating?
Hope you can help me.
Thank you!
 

·
Registered
Joined
·
187 Posts
Have you worked on the bike recently or made any changes? If not and as mentioned, a good place to start is with the simple things like confirming the battery terminals are tight. Some bikes also had an issue with the fuel pump. Can you hear the pump priming when you turn the ignition and kill switch on? You should hear it run for about two seconds.
 

·
Registered
Joined
·
118 Posts
Air Filter blocked? unlikely but could cause those symptoms.

Bad fuel? again unlikely, but possible
It wasn't my GSXS but I had a FZ-07where mice partially filled my air filter with bird seed and random crap. Bike would start and run fine until you got above about 5K and then it would fall over. The bike was parked in an attached garage so I was shocked when I found it.
 

·
Registered
Joined
·
9 Posts
if it's only started to happen during hot weather it could be a bad or blocked intake air temp sensor, know someone who had a similar issue when the temp was below 10c, lift your tank and and pull the sensor to have a look, it's located on the rear right corner of the airbox while your there check the air filter as well. If those are ok then could be fuel filter clogged up.
 

·
Registered
Joined
·
8 Posts
Hi
Unfortunately, I have issues with my bike. If I pull the throttle aggressively, it is starting slow down and feels like its tossing me front to back, like its trying to throw me off, and definitely doesn't want to accelerate.
After 60 mins of downtown riding, I have also noticed this problem without pulling heavy throttle, and in this case, the engine was cut off. I could restart it while I was driving, but it has broken down again after a couple of seconds.
There was a certain case, when I did not succeed with restarting the engine, the starter was just trying to restart it...
Pulled out the key, restarted the engine, and it was OK for a couple mins.
These symptoms started to happen in this hot (35C) weather.
Any idea what is the problem? Fuel pump? TPS sensor? Overheating?
Hope you can help me.
Thank you!
there's a jumper for the fuel pump on the harness under the pillion seat (the one that have the rear indicators \ brake light \ plate light), to see it clearly remove the rider seat as well, its tied with re-usable zip-tie just pull the pin and remove the zip tie, its a square white plug (mine had some condensation on the pins) and did exactly as yours did, worth to check out
 

·
Registered
Joined
·
187 Posts
It IS a California thing. Two sets of bike codes in USA. One for CA; one for everyone else.
@GSXS-NH

If you look at the parts diagrams, they show three different codes for emissions on our bikes. They list E28 and E33, but they also show E03. As far as I know, only the E33 bikes have the CA emissions w/EVAP canister, but I'm not sure what differences there are between the E03 and E28 bikes.
 

·
Registered
2021(updated model) GSX-S1000
Joined
·
1,879 Posts
No response from bali305 ????
 
1 - 20 of 21 Posts
Top