GSXS 1000 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
364 Posts
Discussion Starter #1 (Edited)
Bike used to start up in gear with kickstand up prior to installing a Translogic quickshifter (also LED headlight and moving the stock clutch lever inboard but those seem less likely culprits).

Afterwards, I can't seem to start the bike with the kickstand up unless I'm in neutral, which gets annoying when loading the bike up on ramps, stalling, etc.

Is this normal? What could be causing the issue?

When running, bike still shuts off when I move the kickstand down so I don't think it's a kickstand switch issue.

Clutch lever play is within spec.

I do have a lower handlebar which I had for a while prior to these recent mods and everything was fine.

Clutch switch pin moves in and out, presumably normally. Maybe the switch itself is bad?

Sent from my SM-N960U1 using Tapatalk
 

·
Registered
Joined
·
563 Posts
Clutch switch seems like a likely culprit, but I don't know what goes into installing a quick shift.
Check continuity with a meter if you have one.
You could remove the switch from the perch and let it hang or jump the wires together this would simulate clutch pulled in. Remember though, it would also allow you to start in gear so be pulling your clutch.
 

·
Registered
Joined
·
24 Posts
yeah i would say look at the clutch switch.

i think one way to check without being invasive, is i remember reading about an idle up thing.

if your running sitting on it in N. and you push the cluch in, does the RPM change at all? i guess it's supposed to go from 1k to 1300 or something like that. if nothing changes i'd bet it's the switch
 

·
Registered
Joined
·
259 Posts
Is it on the side stand? Does it do the same when you’re on it and the stand is up? If stand is up with you on it, in gear, clutch in, then I’d definitely go with clutch switch.
 

·
Registered
Joined
·
364 Posts
Discussion Starter #5
When I moved the clutch lever perch inboard, I jammed it right up against the handlebar bend as far as it would go. It didn't occur to me before that the clicking sound that accompanied lever engagement was missing this time around.

After returning the perch outboard, the clicking sound returned and so did the ability to start the engine in gear with the kickstand up!

Thanks for all the replies.

Sent from my SM-N960U1 using Tapatalk
 

·
Registered
Joined
·
309 Posts
Idle speed increases when it is put in gear, actuating the clutch doesn't increase revs
That is not my own observation. If I'm sitting at a light in neutral at idle with the clutch released, and then pull in the clutch and put the tranny into first gear but still hold the clutch fully disengaged, the idle speed doesn't change. It's only when I start to release the clutch while the transmission is in gear that the idle speed increases.
 

·
Registered
Joined
·
563 Posts
You may have your clutch lever adjusted so that even fully pulled to the grip it isn't disengaging the assist. So when you put the bike in gear it idles up.
 
1 - 12 of 12 Posts
Top