GSXS 1000 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1 (Edited)
I just got everything put back together and after going down the road a bit the CEL came on and it's indicating issues with the o2 sensor. If you have a 2018 or newer make SURE that the o2 sensor is disabled or you are going to get the CEL coming on. I am pretty sure I am going to have to ship it back to Danos for a reflash to disable the o2 sensor.

Has anyone found a working plug for the o2 sensor? I have combed the forums and the closest I found was a optimizer from Dynojet.

EDIT:

If you are experiencing surging/hunting/loping after a full exhaust system is installed the o2 sensor should be disabled. If you have a 2017 or older you can just buy an eliminator kit, if you have a 2018+ you need to have the o2 sensor disabled in the ECU through flashing. You should buy a plug for the port on the exhaust as well because leaving the o2 in with the system disabled can damage the sensor. (It is a ~$150.00 part that you can sell or give away, don't destroy it when a plug costs 6.99 on amazon)
 

·
Registered
Joined
·
95 Posts
Discussion Starter #2
Does anyone know if running the bike like this would cause issues with it? I was planning on just leaving it be until the season is over and having it reflashed later.
 

·
Registered
Joined
·
1,187 Posts

·
Registered
Joined
·
85 Posts
I just got everything put back together and after going down the road a bit the CEL came on and it's indicating issues with the o2 sensor. If you have a 2018 or newer make SURE that the o2 sensor is disabled or you are going to get the CEL coming on. I am pretty sure I am going to have to ship it back to Danos for a reflash to disable the o2 sensor.

Has anyone found a working plug for the o2 sensor? I have combed the forums and the closest I found was a optimizer from Dynojet.

EDIT:

If you are experiencing surging/hunting/loping after a full exhaust system is installed the o2 sensor should be disabled. If you have a 2017 or older you can just buy an eliminator kit, if you have a 2018+ you need to have the o2 sensor disabled in the ECU through flashing. You should buy a plug for the port on the exhaust as well because leaving the o2 in with the system disabled can damage the sensor. (It is a ~$150.00 part that you can sell or give away, don't destroy it when a plug costs 6.99 on amazon)
I have a 2018. My bike is not flashed but I have a full Arrow exhaust with a piggy back controller/tuner. My O2 sensor is plugged in and I have no problems whatsoever. I disabled it and that is when the FI light came on, indicating an O2 sensor problem. With it plugged back in, the bike runs perfectly.
 
1 - 4 of 4 Posts
Top