GSXS 1000 Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
Hey my 16 gsxs is at the local shop, about to go pick it up after having a full M-4 installed and get a call from shop can't get the check engine light off. They say that they followed the install instructions supplied by M-4 for disabling the exhaust valve but it's still tripping the light. Anyone have suggestions for this?
 

·
Registered
Joined
·
75 Posts
Discussion Starter #3
I can't, I don't have it in front of me the shop has it.
 

·
Registered
Joined
·
974 Posts
It should have come with an exhaust servo motor eliminator which plugs in place of the motor and if they did then I'm only guessing the eliminator is either the wrong one or faulty ,
 

·
Registered
Joined
·
75 Posts
Discussion Starter #5
He said it come with and they plugged it in,, thru entire Dyno process and test rides there was no problem,, now, there is
 

·
Registered
Joined
·
75 Posts
Discussion Starter #7
I can only suggest that the plug has failed somehow. I wouldn't be too concerned re riding it.
That's kind of what we're thinking too,, seeing show it was good thru all the processes then it wasn't,
 

·
Registered
Joined
·
75 Posts
Discussion Starter #8
So You think the light on won't affect the performance of the bike?
 

·
Registered
Joined
·
75 Posts
Discussion Starter #12
So the tuner took the rest of the weekend off, my bike sitting in his shop, grrrrr. He's going to break it down and double check his work and if that's not a problem get on phone with M-4 on Tuesday and see what they have to say. I'll post and update as we move along.
 

·
Registered
Joined
·
566 Posts
On my racebike you leave the SET motor hooked up and plugged in and remove the cable wheel from the back of the motor and replace it with a half moon looking thing that fools the SET motor into thinking the cables are still in place. Works like a charm and no FI light or codes.

Might want to call M4 but I bet your install guys left this part of the install out. M4 install instructions are not that good.
 

·
Registered
Joined
·
222 Posts
On my racebike you leave the SET motor hooked up and plugged in and remove the cable wheel from the back of the motor and replace it with a half moon looking thing that fools the SET motor into thinking the cables are still in place. Works like a charm and no FI light or codes.

Might want to call M4 but I bet your install guys left this part of the install out. M4 install instructions are not that good.

Or...................


The gears inside are stripped from tightening the "half moon looking thing" improperly.
Easy to check by watching to see if it cycles through or if it just sits there while gears grind.
 

·
Registered
Joined
·
974 Posts
Or...................


The gears inside are stripped from tightening the "half moon looking thing" improperly.
Easy to check by watching to see if it cycles through or if it just sits there while gears grind.


I thought the eliminator plug would eliminate the need for any of this, I could be wrong though
 

·
Registered
Joined
·
1,231 Posts
Hi David,
The issue problem should be displayed if you do the 'jumper' trick same diagnostic plug place under the pillion seat where the -C00 TPS was checked at.
Then they can say what actually is triggering the ECU alarm light. It could be a broken air/ fuel sensor during the dismantle or the SET Valve. It will be presumably one or the other.


The M4 site has no install instructions, but some info saying that it has a 18 mm threaded connection and a 12 mm adaptor for the lamba air /fuel mixture sensor and not much else. M4 Exhaust · High Performance Motorcycle Exhaust Systems


The picture on the site of the full system has no sign of the SET Valve and the link above doesn't say anything about an eliminator.


Rob
 

·
Registered
Joined
·
371 Posts
Hey my 16 gsxs is at the local shop, about to go pick it up after having a full M-4 installed and get a call from shop can't get the check engine light off. They say that they followed the install instructions supplied by M-4 for disabling the exhaust valve but it's still tripping the light. Anyone have suggestions for this?
Step 1... Which code do you have? Put the bike into dealer mode and check the code and then get back to us.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #18
Step 1... Which code do you have? Put the bike into dealer mode and check the code and then get back to us.
the code is for the SET, Joe got a hold of M-4 today and they suggested he didn't cycle/clock the valve cables correctly before installing their bypass piece, (I haven't seen any of this cause the bike is in the shop 30 miles away and getting there is not possible for me right now) thus not positioning the piece/cables with the correct clocking and tripping the light. So tomorrow he is going to follow their instructions and reclock/cycle the cables before hooking it up to this piece and see what happens.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #19
Hi David,
The issue problem should be displayed if you do the 'jumper' trick same diagnostic plug place under the pillion seat where the -C00 TPS was checked at.
Then they can say what actually is triggering the ECU alarm light. It could be a broken air/ fuel sensor during the dismantle or the SET Valve. It will be presumably one or the other.


The M4 site has no install instructions, but some info saying that it has a 18 mm threaded connection and a 12 mm adaptor for the lamba air /fuel mixture sensor and not much else. M4 Exhaust · High Performance Motorcycle Exhaust Systems


The picture on the site of the full system has no sign of the SET Valve and the link above doesn't say anything about an eliminator.


Rob
thanks rob, at least now i know what pieces he's talking about,, this whole process has been frustrating for me with the bike being out of my hands and me not participating in the install.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #20
By the way, here's the chart of what we got out of the bike on a dyno after XTRE M4 full and custom map. Joe the map that came with pc sucked out of the hole annlaunch was terrible,
 

Attachments

1 - 20 of 21 Posts
Top