GSXS 1000 Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I recently bought a ‘18 1000, and it appears completely stock. Each time I rode it after buying it the engine light came on. In disgust I took it to the dealer, and after checking the bike, found the tuner and removed it (I still have it) my question is there a user’s guide available anywhere? I’ve ordered a K&N, and will be changing the mid pipe and muffler soon, and have no clue how to use the tuner. I’m never available during their business hours, so I hoped to find a manual of some sort to reference. Thanks
Wheel Tire Fuel tank Vehicle Automotive tire
 

·
Registered
Joined
·
873 Posts
What brand is it ?
Power commander or Bazzaz?
On some of the sites for these companies they will have some maps for different bikes with different mods..
Just wondering if the engine light is still on if it is check connection for 02 sensor.
You should sell the tuner and while your doing mods send ecu off to be flashed for the mods.
Ecu flash is the way to go👍
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
It is holeshot brand. The engine light went off after removing the tuner. I had planned to send it off for tuning as I made the changes, then found out it had this tuner with it. Still will probably send it for tuning.
 

·
Administrator
Joined
·
639 Posts
Leave it removed and get the ECU flashed. Holeshot tuner works great on pre 2018 bikes. Should you chose to re-install it, Google Dale Walker at Holeshot Performance in Nevada.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I went for a ride earlier and the cel reilluminated. C45 which is the same code as the first two times. I’m going to disassemble the bike and check connections, K&N already on the way, so it’ll be apart to install. What I’ve read is it is a possible iac issue, so I’ll check it. It came on after I goosed it to get through a yellow light, which as I think back is when it came on the last two times; after it quickly accelerating to merge or get out of the way of a bad driver.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
So to update in case anyone runs into the same issue. I found 2 things when I had the bike apart. Previous owner Installed a K&N, and the shop left the O2 simulator plugged in after removing the tuner. I removed the simulator, and rode for a while. The light went off after riding a while and I stopped for a break, and never came back on. So when I change the exhaust I will send the computer off for reflash, and will be selling the holeshot cheap
 

·
Registered
Joined
·
713 Posts
So to update in case anyone runs into the same issue. I found 2 things when I had the bike apart. Previous owner Installed a K&N, and the shop left the O2 simulator plugged in after removing the tuner. I removed the simulator, and rode for a while. The light went off after riding a while and I stopped for a break, and never came back on. So when I change the exhaust I will send the computer off for reflash, and will be selling the holeshot cheap
So you ordered a K&N filter and now found out there's already one installed? Would have been a good idea to check and see if it already had a performance air filter in it before ordering one. Lol. Also, don't mess around with reinstalling the Holeshot tuner. The best option is to have the bike tuned in person by a reputable tuner, but if that isn't possible, send the ECU out to be flashed. Dano's Performance or Moore Mafia would be my recommendation for a flash.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
With dealing with only being able to ride the bike twice and having it back at the dealer I never had to opportunity to pull the tank. When it came on yet again, I decided I’d figure it out since they couldn’t. When I asked if it had any aftermarket parts, they assured me it was stock, so I took their word for it. I’ve already cancelled the filter, so no loss. There is a dynojet tuner shop in town, I plan to just send my ecm to Dan when I have my parts in for install. That way I know what’s been done.
 

·
Registered
Joined
·
713 Posts
With dealing with only being able to ride the bike twice and having it back at the dealer I never had to opportunity to pull the tank. When it came on yet again, I decided I’d figure it out since they couldn’t. When I asked if it had any aftermarket parts, they assured me it was stock, so I took their word for it. I’ve already cancelled the filter, so no loss. There is a dynojet tuner shop in town, I plan to just send my ecm to Dan when I have my parts in for install. That way I know what’s been done.
Good results can be had from the generic mail-in ECU flashes, but you'll always end up with a better result when having your bike tuned in person on a dyno by a knowledgeable tuner.

I had Dano flash my 2020 GSX-S1000 ECU about a year ago and I was initially very happy with it because it was such a dramatic difference in the way power was delivered. As seat time on the bike has progressed and as mileage has increased, I've started to notice the small issues that come along with having (essentially) the same flash everyone gets, which as I mentioned previously, is generic and predetermined. The small things that require dialing in for each particular bike that can only be corrected while on the dyno really make the difference between a spot on perfect tune and a mail-in flash. I plan on having Chris Moore tune my bike as soon as I get some free time to get it down to him. I'm really looking forward to getting the bike dialed in and rectifying the couple things that need fixed. I could have saved a lot of time, money, and aggravation by going this route from the start, but we live and learn.

That said, the majority of people are just fine with the results of a mail-in flash. They may not ride enough, care enough, or be picky enough to want to spend their time and money having a bike dialed in on the dyno for several hours. You just have to decide what's most important for you and your needs.
 

·
Registered
Joined
·
20 Posts
I went for a ride earlier and the cel reilluminated. C45 which is the same code as the first two times. I’m going to disassemble the bike and check connections, K&N already on the way, so it’ll be apart to install. What I’ve read is it is a possible iac issue, so I’ll check it. It came on after I goosed it to get through a yellow light, which as I think back is when it came on the last two times; after it quickly accelerating to merge or get out of the way of a bad driver.

Same thing happened to me with the Holeshot tunner from Dale. Same code same conditions! I to bought the bike not knowing about the tunner. Turns out the previuos owner had just installed it less than 6 months before I bought the bike. Spoke to Dale and he told me I was out of luck in so many words! Bought the ECU flash and quick shifter from Dano. Very happy!
 
1 - 14 of 14 Posts
Top