GSXS 1000 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hi, I was putting in a cable to charge my phone and running it alongside the other cables on the bike and so i had the fuel tank up to run the USB cable. This meant that the immobilizer was still connected but hanging down side of the fuel tank. For some unknown reason I then put the key in and turned it to the on position. I reassembled the plastics and sat the immobilizer where it belongs but ever since then I have had the FI light on with error code 42 - IGNITION SWITCH SIGNAL.

The bike starts, but I don't want to have an error code constantly. How can I fix this? Woops!


Mike.
 

·
Registered
Joined
·
1,235 Posts
Hi, I was putting in a cable to charge my phone and running it alongside the other cables on the bike and so i had the fuel tank up to run the USB cable. This meant that the immobilizer was still connected but hanging down side of the fuel tank. For some unknown reason I then put the key in and turned it to the on position. I reassembled the plastics and sat the immobilizer where it belongs but ever since then I have had the FI light on with error code 42 - IGNITION SWITCH SIGNAL.

The bike starts, but I don't want to have an error code constantly. How can I fix this? Woops!


Mike.
Normally the bike will only show the FI light if you have a error at the time, once the issue is fixed it should disappear, but if the error is from something being disconnected it will stay in memory but not show FI

Use SDS tool or Woolich flashing software and interface to clear, alternatively disconnect the battery.

I have had error 42 and FI just due to a lowish battery.
 
1 - 2 of 2 Posts
Top