GSXS 1000 Forum banner
21 - 40 of 40 Posts

·
Registered
2021(updated model) GSX-S1000
Joined
·
1,886 Posts
Does any body have a picture of the vent hose under the tank. I am wondering if the hose with the t was not installed correctly.

Sent from my SM-N976U using Tapatalk
45517


Items 21&22 are located more or less vertical on the bike
 
  • Like
Reactions: Gixxus_Lou

·
Registered
Joined
·
93 Posts
Discussion Starter · #22 ·
Thank you guys. Those are the same way my hoses are. I was hoping.

Sent from my SM-N976U using Tapatalk
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #23 ·
A little more info. So I took the bike out for another ride. 10 minutes into the ride. Bike starts to surge high rpms. Pull over turn bike off and pop the gas cap. No psst sound or abnormal cap release. Start bike up and rides great. 5 minutes later, starts to surge at high rpms. Thinking I have a vent issue even though I verified no kinked lines. I pull over, turn the bike off and pop the gas cap but this time I leave it open. Start the bike up and runs great for around 5 minutes then starts to surge again at high rpms. Repeat the process and close the tank up then ride the rest of the way home. Longer I ride the lower the rpms the surging takes place.

Makes me wonder if it's electrical instead fuel pump. Unless the priming of the fuel pump has anything to do with how its running. I am completely stumped on this issue.

Sent from my SM-N976U using Tapatalk
 

·
Registered
Joined
·
356 Posts
Interesting - it does sound like a fuel supply issue at those higher rpm's when more fuel is needed. I'm not sure if these bikes have a fuel filter but that may be clogged a bit?
 

·
Registered
2021(updated model) GSX-S1000
Joined
·
1,886 Posts
Do a forum search, #13 on this thread for a start.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #26 ·
There is a filter on the fuel pump. The bike only has 4k miles on it. The pump and filter was changed new at around 640 miles.

Sent from my SM-N976U using Tapatalk
 

·
Registered
Joined
·
651 Posts
I am losing trust with this bike let alone the frustration.
UNderstood and unfortunate as the bike is a great bike. Yours being an exception.
Been a while since you posted. Has the bike been to the dealer yet for an update?
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #28 ·
UNderstood and unfortunate as the bike is a great bike. Yours being an exception.
Been a while since you posted. Has the bike been to the dealer yet for an update?
The bike has been there for a week. Dealer swapped plugs, I told them that won't fix it but the are checking boxes of possibilities. Checked flow and it met spec but so did the first pump that failed. They have been calling suzuki and trying to figure the bike out.

Sent from my SM-N976U using Tapatalk
 

·
Registered
Joined
·
651 Posts
The bike has been there for a week. Dealer swapped plugs, I told them that won't fix it but the are checking boxes of possibilities. Checked flow and it met spec but so did the first pump that failed. They have been calling suzuki and trying to figure the bike out.

Sent from my SM-N976U using Tapatalk
Lemon law apply by any chance? Shame to completely rule out the bike because of your experience. In your shoes, I probably would as well though, unless I could get a completely different bike. OR, the dealer finds the "silver bullet" root cause and I felt confident in their findings. Otherwise, you could never trust the bike. Without being able to trust it, you cannot enjoy it.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #30 ·
Lemon law apply by any chance? Shame to completely rule out the bike because of your experience. In your shoes, I probably would as well though, unless I could get a completely different bike. OR, the dealer finds the "silver bullet" root cause and I felt confident in their findings. Otherwise, you could never trust the bike. Without being able to trust it, you cannot enjoy it.
Lemon law won't apply in Delaware where I bought the bike. I looked into it. If the issue can't get figured out. I will trade it in on either the mt10 or the new gsxs1000. If I can find a used super duke, for a decent price I will look at that possibly.

Sent from my SM-N976U using Tapatalk
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #31 ·
Finally took possession of the bike. It's ran good on my 70 mile test ride. Seems the plugs may have been the issue. Hopefully it stays running right.

Sent from my SM-N976U using Tapatalk
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #33 ·
Only 3800 when it started to act up again. Me and the dealer think that when the first fuel pump failed and caused me to run lean. Opened up the gap on the plugs, maybe caused it to knock and cut. Who knows but it's running good so far. I just hope it stays this way.

Sent from my SM-N976U using Tapatalk
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #35 ·
Pretty sure I have the gsxs1000 from ****. This stupid bike is doing the same problem again. Only tool 460 miles after owning the bike to cut out again. Either going to deal with the dealer or I am trading for mt10.

I am wondering if the tps sensor loosened up and is out of adjustment. That's the only thing that I can think of that would change from what the dealer did.

Sent from my SM-N976U using Tapatalk
 

·
Registered
Joined
·
336 Posts
Pretty sure I have the gsxs1000 from ****. This stupid bike is doing the same problem again. Only tool 460 miles after owning the bike to cut out again. Either going to deal with the dealer or I am trading for mt10.

I am wondering if the tps sensor loosened up and is out of adjustment. That's the only thing that I can think of that would change from what the dealer did.

Sent from my SM-N976U using Tapatalk
I’m sorry to hear about your problem bike. I would be very frustrated too! For the most part it seems that these bikes are pretty bullet proof but you were unlucky enough to have gotten one with problems. I would be bailing on it too.
 

·
Registered
Joined
·
651 Posts
Pretty sure I have the gsxs1000 from ****.
Sorry to hear. That takes the enjoyment out of it. Don't blame you for looking elsewhere.
Are you sure you are not hitting the ignition cutout? In your vid the RPMs seemed at redline.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #39 ·
Sorry to hear. That takes the enjoyment out of it. Don't blame you for looking elsewhere.
Are you sure you are not hitting the ignition cutout? In your vid the RPMs seemed at redline.
100% not ignition cut out and it's not at redline.

Sent from my SM-N976U using Tapatalk
 

·
Registered
Joined
·
651 Posts
100% not ignition cut out and it's not at redline.
Copy. Video wasn't 100% clear so wanted to verify.
That really sucks because when it works it's great. Sucks when it doesn't.
 
21 - 40 of 40 Posts
Top