GSXS 1000 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I bought LED rear turn signals installed them only to find out I needed resistors...I went to the dealer and ordered the front turn signals and purchased the resistors...I went home and with the stock front turn signals and the rear LED turn signals with resistors, the flashed normal...The front LED ones came in and now they're rapid flashing again...DO I HAVE TO CRAM RESISTORS in the front or can you guys point me in the direction of a flasher relay that would work? And if I opt to go with the flasher relay will it be okay with the resistors I already installed or would I have to remove those? Thank you!
 

·
Registered
Joined
·
286 Posts
I bought LED rear turn signals installed them only to find out I needed resistors...I went to the dealer and ordered the front turn signals and purchased the resistors...I went home and with the stock front turn signals and the rear LED turn signals with resistors, the flashed normal...The front LED ones came in and now they're rapid flashing again...DO I HAVE TO CRAM RESISTORS in the front or can you guys point me in the direction of a flasher relay that would work? And if I opt to go with the flasher relay will it be okay with the resistors I already installed or would I have to remove those? Thank you!
I managed to fit Rizoma resistors, which are quite large, into the front headlight housing no problem while waiting for my relay to arrive from China. I removed the resistors when I installed the relay.
 

·
Registered
Joined
·
593 Posts
I'd give you a link for the relay in the UK, but I have no idea if it would be any use to you :rolleyes:
 

·
Registered
Joined
·
849 Posts
More, never-ending proof that 99% of dealerships are staffed by MORONS. They NEVER touch my bike.

I put in LEDs and they flashed fast. I got a new FLASHER from Amazon for under $10, installed it under the seat in five seconds and they flash normally. Heck, this one is even adjustable.

Here it is, problem SOLVED...

https://www.amazon.com/gp/product/B011BTMDQM/ref=oh_aui_detailpage_o06_s00?ie=UTF8&psc=1

And you're interested, these are the excellent bulbs I put in the rears and went with flush mounts in the front.

https://www.amazon.com/gp/product/B00WVLNJ54/ref=oh_aui_detailpage_o06_s00?ie=UTF8&psc=1
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7
Okay I'll be taking the resistors out...Just purchased that one on amazon for like 10$ish...thanks a lot for your help!
 

·
Registered
Joined
·
849 Posts
Okay I'll be taking the resistors out...Just purchased that one on amazon for like 10$ish...thanks a lot for your help!
Sure thing! If it's still flashing fast (or too slowly) with the new flasher installed, take a little screwdriver and adjust it while the signals are on. I can't remember where the default setting was from the factory.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #11
thanks stromer...worked great...I had to turn it all the way down and it works great! I left the resistors I installed in because I don't feel like wiring them up again! good to go now though!
 

·
Registered
Joined
·
849 Posts
thanks stromer...worked great...I had to turn it all the way down and it works great! I left the resistors I installed in because I don't feel like wiring them up again! good to go now though!
Awesome! The simplest solution is always the best :)
 
1 - 12 of 12 Posts
Top