GSXS 1000 Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
Hi all fitted K&N and power commander to my 2017 phantom model Sunday . Already has yoshi R11 can . Used standard map for now as when finances allow gonna go for headers and decat , then get a custom map made . Pulled the baffle from the air box while I was in there , read pros and cons , I'll be happy if it makes it growl a little more ! As I got done it pissed down right on que so road test ll have to wait till coming weekend . It did sound and respond noticeably better to the throttle on starting , warming up . Very easy fit well made for anyone thinking of doing it . I'll report back after test .
Stina
 

·
Registered
Joined
·
58 Posts
Discussion Starter #2
Ok , got to take it out today . It was running great and felt good for the first 5 miles or so , then I looked down at about 70 and the engine light was on and Fi was flashing . Bike still sounded and ran sweet . I just kept going and left it at the dealers , they're gonna look at it Monday . Seems strange how it was ok for a while , they said it may not be related to the pcv . Any ideas ?
 

·
Registered
Joined
·
364 Posts
Maybe you forgot to re-connect one of the plugs around the air box or an issue with the connection of the O2 eliminator plug the comes with the PCv, just thoughts. If you still had the bike you could have bridged the service plug and posted up the fault code on here and got an answer to the problem area from the fault codes listed in my service manual.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #4
Yeah I agree with that , but what was gonna be a test just to confirm all ok turned into a head scratcher , as I was a couple miles off the dealer I didn't want to shut it off and risk it not going again . So I left it with them as its still under warrantee , dragged the old man out for a lift home and I'll have to wait and see . Seems strange as the traction control seemed to be doing its own thing as I got there too ! The real heart ache is that I was talking to the sales man there that I px 'd my k5 with and they dyno' it for the new owner at 179 wheel Hp ! Never did wanna sell it , just too crippled up for a sports bike now 😉
 

·
Registered
Joined
·
29 Posts
Had this same fault when i fitted my quickshifter, fi light came on after a couple of miles traction went crazy. disconnected battery again reconnected and its been fine ever since, just a thought
 

·
Registered
Joined
·
58 Posts
Discussion Starter #6
Picked it up yesterday after shifting things around to make time . Got told they checked the pcv fitment all ok and the code related to the tank being removed (it hasn't ) and they'd ridden it 10 miles all ok . 5
Miles into ride home and light back on . Its with them again and I'm not overly impressed . I reckon they did no more than clear the code and send it back out !
 

·
Registered
Joined
·
58 Posts
Discussion Starter #7
Update . The dealer fitted another o2 eliminater under instruction from dynojet uk . This was about 3 weeks ago . The light and code stayed off all the way home . I rode it to work next day as I had little faith in it . Sure enough it came back on , so back to dealer on way home . It was giving a fuel trim code . So we spoke to dynojet and they admitt to having trouble with late 2017 & 18 bikes . They leased with dynojet America and sent me an o2 optimiser as oppose to eliminater . Took about 2 weeks in which time I just disconnected the pcv and ran it as standard . Fitted it all up Friday nite when I had the eliminater and rode it 200 miles Saturday with no issues , it's more of the bike I was hoping for now . Expensive fix for dynojet , they are aware of a problem fitting pcv and o2 eliminater !
 

·
Registered
Joined
·
31 Posts
Do you have part number for optimizer?
 

·
Registered
Joined
·
52 Posts
Installed a throttle tamer and took the slack out of the throttle cable.

Holy crap. Completely different bike. I liked it before, but now its amazing. My throttle wasn't in the "terrible" category for snatchiness, but it was noticeable. Now? It feels like my BMW. Linear throttle, no issues with 20-40mph corners, just so much more stable.

Oh, and I fitted a Nelson Rigg tail/seatbag for my commute.
 

·
Registered
Joined
·
51 Posts
Update . The dealer fitted another o2 eliminater under instruction from dynojet uk . This was about 3 weeks ago . The light and code stayed off all the way home . I rode it to work next day as I had little faith in it . Sure enough it came back on , so back to dealer on way home . It was giving a fuel trim code . So we spoke to dynojet and they admitt to having trouble with late 2017 & 18 bikes . They leased with dynojet America and sent me an o2 optimiser as oppose to eliminater . Took about 2 weeks in which time I just disconnected the pcv and ran it as standard . Fitted it all up Friday nite when I had the eliminater and rode it 200 miles Saturday with no issues , it's more of the bike I was hoping for now . Expensive fix for dynojet , they are aware of a problem fitting pcv and o2 eliminater !
Hmm, this bit concerns me. I've got a 2018 model and was going to get a PCV fitted once the bike's run in but was unaware there were problems with 2017/2018 model PCVs
 

·
Registered
Joined
·
58 Posts
Discussion Starter #12
Hi . But it's not a problem now . You just need the optimiser rather than the eliminater . I'd advise speaking to and buying direct from dynojet . They'll put you right 😀 Urelated , Mines a 1000 z too 😀
 

·
Registered
Joined
·
19 Posts
Hi . But it's not a problem now . You just need the optimiser rather than the eliminater . I'd advise speaking to and buying direct from dynojet . They'll put you right Urelated , Mines a 1000 z too
+1

100% agree with stina on this. I was having issue with FI light and called dynojet. They shipped me an optimizer (apparently it comes standard with UK orders but not in Canada?) . Installed today and no more FI light (means running two 02 sensors). Also made sure to block off pair valve and made sure there were no leaks in my aftermarket exhaust (gaskets joins etc). I would have been lost without this forum so BIG thanks to Stina! :)

Sent from my BKL-L09 using Tapatalk
 

·
Registered
Joined
·
370 Posts
From what I read after putting in a PCV the best results is to have the bike dynotuned. I guess to put the best map for the bike ??
 
1 - 15 of 15 Posts
Top