GSXS 1000 Forum banner

1 - 20 of 67 Posts

·
Registered
Joined
·
437 Posts
Discussion Starter #1
Ok who else has a sticking select switch??? :eek:
Hopefully it will be resolved when she is in for first service next week
 

·
Registered
Joined
·
37 Posts
Ok who else has a sticking select switch??? :eek:
Hopefully it will be resolved when she is in for first service next week
Yeah mines stuck too and cannot change traction modes, another recall, sounds like a bad batch of switch's. Tried WD 40 etc but no good.
 

·
Registered
Joined
·
437 Posts
Discussion Starter #4
That don`t seem good if switch not even making it to the 1st service. :eek:
It does work it just sticks in sometimes and has to be prised out with a finger tip
 

·
Registered
Joined
·
437 Posts
Discussion Starter #6
Been there done that 😄
 

·
Registered
Joined
·
437 Posts
Discussion Starter #8
Mines been ok. I'm sure KC will sort it out.
Mentioned it to Craig when I booked its first service so hopefully be sorted when I pick it up next week
 

·
Registered
Joined
·
437 Posts
Discussion Starter #9
Got the beast back this morning from first service and they have lubricated said sticking switch and now all appears well, they didi also say if it happens again they will replace it.
It seems strange that this is the same unit fitted to the vstrom 1000 and so far the dealership has no reported issues with the switch. Maybe I just clean the bike to often
 

·
Registered
Joined
·
237 Posts
Got the beast back this morning from first service and they have lubricated said sticking switch and now all appears well, they didi also say if it happens again they will replace it.
It seems strange that this is the same unit fitted to the vstrom 1000 and so far the dealership has no reported issues with the switch. Maybe I just clean the bike to often
Must learn one day how to clean a bike;)
 

·
Registered
Joined
·
593 Posts
Has anyone had theirs replaced yet? Mine's always been a little sticky, but now it just refuses to release by itself. Lubricating with GT85 (smells nicer than WD-40 :)) made no difference, even by taking the rocker switch cap off to get underneath :(
 

·
Registered
Joined
·
87 Posts
mine did the that for a bit had a bit of grit stuck in there got that out and have had no more problems
 

·
Registered
Joined
·
58 Posts
After 1000kms I have had no issues.
 

·
Registered
Joined
·
1,382 Posts
Had my first experience of sticking "set switch" today while out for a ride.
Took the unit off and tried to lubricate the bit of the plunger that you can see underneath,
it made no difference.
 

·
Registered
Joined
·
593 Posts
Mine is still sticking... I'll get it in to my local Suzuki dealer when the weather improves!
 

·
Registered
Joined
·
1,249 Posts
And now mine has started to stick too.
Funny thing was, I'm sure it wasn't sticking before it went in for its service.
 

·
Registered
Joined
·
249 Posts
Well 2k miles in the select button has started sticking for me (it could have been before as i dont use it that much). It presses in then either comes back out sluggishly or sticks down completely requiring a wiggle.

Not the end of the world but i can imagine this being a pain when the warranty runs out for some.
 

·
Registered
Joined
·
1,249 Posts
I had mine bake in for some warranty work last week and whilst there i complained about the switch and also the ignition switch which had jammed and wouldn't let me put the key all the way in.
The garage added it to the work list and cleaned and lubed both switches. So far so good. I did wonder if it was just the colder weather making the grease go a bit too thick and stuffing everything up.:|
 
1 - 20 of 67 Posts
Top