GSXS 1000 Forum banner

21 - 31 of 31 Posts

·
Registered
Joined
·
1,425 Posts
Whatever it is the engine is running very rich.
Faulty temperature sensors maybe?
I love a good mystery but hope you get sorted soon. (y)
 

·
Registered
Joined
·
115 Posts
To me, the throttle position readings sound off. No way should it be 85.5% at idle??
 

·
Registered
Joined
·
18 Posts
Hi Guys

Yesterday out riding, and after 2 min. i made a stop.. my idle rpm was around 1500 at that time - a bit more than normal..
Riding a bit more, and then the idle rpm. went to 2000.. it stayed there at every stop i made, the bike was also a bit different to ride.. a lot of stuttering at low rpm.

Went home shut the engine off.. and now the engine wont start - this small video shows what happens when i try to start the engine.


Anyone seen anything like this and have an idea what it can be ? Spark plugs ? Fuel problem ?

My bike is a 2018 with 8000 km - haven't had the first service yet as it has been in a stand still at the dealer from start 2019 to start 2020.
That's very good information to know I just purchased a 2020 GSX S1000 and I put my self almost 315 miles on bike now im concerned about it breaking down I hope it don't as I really love my bike and obviously it's under warranty and has less then 1000 miles on bike if it does break down I'll get ride of it and get something else..
 

·
Registered
Joined
·
14 Posts
Discussion Starter #25
UPDATE - and a positive one..

The faulty part ended up being the TPS.
After installing a new one and adjusting it, the bike runs better than ever.
The part is naturally payed for by Suzuki under warranty - now the bike is being serviced and packed away till spring.
Some parts have been sent for a bit of paint and can’t wait to get my decat exhaust + translogic quick shifter on before mapping of my PC V 👍🏻
thank you everyone for helping out.
 

·
Registered
Joined
·
690 Posts
May I ask, are you the first owner and did you ever attempt to adjust the tps or have anybody else attempt to adjust it?
It seems quite odd that a tps would fail without human intervention especially when so new.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #30
May I ask, are you the first owner and did you ever attempt to adjust the tps or have anybody else attempt to adjust it?
It seems quite odd that a tps would fail without human intervention especially when so new.
Second owner, bought the bike in February 2020 and it had driven 1900 km.
Don’t know if the previous owner have been messing around with it..
 

·
Registered
Joined
·
115 Posts
UPDATE - and a positive one..
.......
The faulty part ended up being the TPS.
Thanks for the update. It sucks when someone makes a first post like yours then never follows up with the resolution. You did. Thanks.
 
21 - 31 of 31 Posts
Top