GSXS 1000 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Why does my TPS show C00 without -or_? Anyone? I have an issue with my idle speed and i wanted to adjust the TPS, but before the dash displayed an F1 and engine line light, i put the bike in dealer mode and it displays C00 but now when F1 light came on i put it back in dealer mode and got C65. Been idling out of range of late though.
 

·
Registered
Joined
·
30 Posts
Hi I suspect you have a later model (2018), C00 - was the earlier model and showed if TPS required adjustment from the instrument display. The later model you have to measure the voltage at the TPS and then adjust as required, C65 is fault code for out of range idle specification as you have noticed. C65 has been reported by others who have replaced the clutch lever from what I've read on here. Something to do with the clutch switch which tells the ECU that you are releasing/engaging the clutch or not ??
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Hi I suspect you have a later model (2018), C00 - was the earlier model and showed if TPS required adjustment from the instrument display. The later model you have to measure the voltage at the TPS and then adjust as required, C65 is fault code for out of range idle specification as you have noticed. C65 has been reported by others who have replaced the clutch lever from what I've read on here. Something to do with the clutch switch which tells the ECU that you are releasing/engaging the clutch or not ??
Thanks, its true I have a 2018 GSX S1000F, so to be sure if what your telling me, I should adjust the TPS using a voltmeter? and also change the clutch switch to fix the issues? FOR YOUR INFORMATION, am not good at English so I will try as mush as I can to understand.
 

·
Registered
Joined
·
30 Posts

Hi, This video shows how to set the TPS on a 2018+ model using a voltmeter. The video shows using an breakout cable to read the TPS voltage.


You can back probe the TPS connector using a good back probe tool kit .Do a search on using a adaptor/patch cable or a back probe tool.
I would make sure the clutch switch is working properly first as it is the easy part to get at :) .
On my 2019 bike ( I have the standard clutch lever ) WITH the lever pulled in the switch is ON a as the lever is released at about 15mm from the handlebar grip the switch is OFF. Hope this helps.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
This was really helpful, i didn't have a break out lead cable to measure the TPS but I used sharp needle on my multimeter probes to connect to the TPS p/b wire and B/BR wire. The measurements were 1.138v on closed throttle and 4.58 on open throttle which is okay according to the Manual. So what I did to remove the error c65. I un plugged the clutch switch cleaned it up and then replugged it back. Then took the bike out for a ride after some few miles the error went off engine light went off as well. I hope it's now okay. When I start it the rev meter is back at 1.1

Thanks guys for the help.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
Guys am back, the error C65 came back on, i changed the clutch switch first, it cleared off the dash, then later re appeared and its annoying, i replaced the Idle speed valve, it disappeared and came back after a few days, its now off but what next?:confused:
 
1 - 7 of 7 Posts
Top