GSXS 1000 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I just ordered a full exhaust system for my bike, and they have a bung welded in to re-use the O2 sensor, but I'm also being told its better to delete the sensor since I will be using a hotshot tuner? But I can't find a O2 eliminator in the USA.
 

·
Registered
Joined
·
383 Posts
I just ordered a full exhaust system for my bike, and they have a bung welded in to re-use the O2 sensor, but I'm also being told its better to delete the sensor since I will be using a hotshot tuner? But I can't find a O2 eliminator in the USA.
I can't find the thread at the moment, but as I recall someone bought a kit off ebay. It ended up throwing an error code anyway, maybe due to his bike being a newer model year?

I have a full M4 system on mine. Initially, I left the O2 sensor in place and didn't disable it when I had my ECU flashed by Dano. Found that when I removed the muffler baffle, I got surging at lower revs. Heard from others that plugging the O2 sensor off (12mm, I have an extra if you're in the US, PM me) and disabling it in the ECU will get rid of the surging, which I did later on along with a PAIR valve delete. Haven't had a chance to test it yet due to weather.

Weather is nice today and I am feeling quite dickish...

Sent from my SM-N960U1 using Tapatalk
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
That is good to know. From what I'm told the 2018+ had a different code for the O2 sensor and that is why some of the delete kits don't work. Mine is a 2018. The exhaust system I ordered has a bung so I'm not sure if I can just re-install the O2 sensor and leave it or what.
 
1 - 5 of 5 Posts
Top